Save the Router Configurations to a TFTP Server :
________________________________________
Follow us on Facebook
Follow us on Google+
________________________________________
Introduction:
Once the configuration is complete our routers, it is important to store these configuration files. Indeed, the critical networks it is often necessary to have spare routers pre-configured to operate at a quick replacement in case of failure. To do this, you can import and export configurations on TFTP servers.
TFTP server:
TFTP for Trivial File Transfer Protocol is a protocol of the TCP / IP stack that enables the exchange of information between nodes. As its name suggests, this protocol is simpler than FTP and can not authenticate users.
In this example, the server address is 192.168.10.222 (address of the machine on which you installed the TFTP server).
Copy configuration to a TFTP server:
Addresses our TFTP server and an Ethernet interface of the router must be on the same network ...
Privileged mode, type copy startup-config tftp
The router then asks the server address, in which case type 192.168.10.222
Finally you are asked to enter the name of your configuration file.
Privileged mode, type copy startup-config tftp
The router then asks the server address, in which case type 192.168.10.222
Finally you are asked to enter the name of your configuration file.
You can see on the router that the file has been sent and copied, you can also check on the
TFTP server
Let us now see what looks like the file saved.
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname LabA
!
enable secret 5 $1$ka36$a8XgHYpt63DVTZWLQxRxP1
! ip subnet-zero
ip host LabC 204.204.7.1 199.6.13.2 223.8.151.1
ip host LabD 204.204.7.2 210.93.105.1
ip host LabE 210.93.105.2
ip host LabB 201.100.11.2 199.6.13.1 219.17.100.1
!!! interface Ethernet0
ip address 192.5.5.1 255.255.255.0
no ip directed-broadcast
! interface Serial0
ip address 201.100.11.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
clockrate 56000
! interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router rip
network 192.5.5.0
network 201.100.11.0
! ip classless
!! line con 0
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname LabA
!
enable secret 5 $1$ka36$a8XgHYpt63DVTZWLQxRxP1
! ip subnet-zero
ip host LabC 204.204.7.1 199.6.13.2 223.8.151.1
ip host LabD 204.204.7.2 210.93.105.1
ip host LabE 210.93.105.2
ip host LabB 201.100.11.2 199.6.13.1 219.17.100.1
!!! interface Ethernet0
ip address 192.5.5.1 255.255.255.0
no ip directed-broadcast
! interface Serial0
ip address 201.100.11.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
clockrate 56000
! interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router rip
network 192.5.5.0
network 201.100.11.0
! ip classless
!! line con 0
login
transport input none
line aux 0
line vty 0 4
password cisco
login
!
end
Retrieve a configuration from a TFTP server on a router:
To copy a configuration file from a TFTP server to our router, so just
configure an Ethernet interface with an address on the same network as the TFTP server.
Then tape copy tftp startup-config
It indicates the address of the TFTP server and the name of the configuration file.
configure an Ethernet interface with an address on the same network as the TFTP server.
Then tape copy tftp startup-config
It indicates the address of the TFTP server and the name of the configuration file.
The configuration is copied to NVRAM, you must then copy the
working memory of the router: copy startup-config running-config